Sign in to follow this  
Followers 0
Almark

Sierra 10.12.2, probs running PTE Mac apps [SOLVED]

19 posts in this topic

Hi folks,

I (foolishly) updated my iMac to Sierra 10.12.2.  I then went over to the dark side, Windows on my Mac, and updated to the latest version of PTE V8.  I worked on a show, saved it as an app and went back to the bright side.  But the newly created app would not run. I get a black screen for less than a second and then back to the Mac screen.

At first I thought it might be a bug in the lastest version 8, but then I tried to run other PTE Mac apps and none of them now work!  So, now I am thinking that 10.12.2 is the problem. Has anyone else found this?

photographers_paradise.app.zip

Share this post


Link to post
Share on other sites

Terminal gives me this... I have absoultly no idea what it means, but thought that someone here might!?

Last login: Fri Dec 16 01:33:26 on ttys000

Mark-Allens-iMac:~ markallen$ /Volumes/MARK_A_One_TB/_iceland/photographers_paradise.app/Contents/MacOS/launcher ; exit;

[maclauncher] launching application: "/Volumes/MARK_A_One_TB/_iceland/photographers_paradise.app/Contents/Resources/Viewer.app/Contents/MacOS/MacViewer5"

[maclaucnher] launch result = TRUE

Assertion: Incorrect RefObject: "TMacStore" contruction COUNT, possible INHERITED CREATE is not call or too many _Release calls at wpTypes.pas line:474 addr 0052BB10

Call Stack: 

  $0001D2A1

  $000230F4

  $00040CD1

  $0004059C

  $000869FD

  $0009ED78

  $0009FCB6

  $00093DB4

  $00094A8A

Assertion:  at wnTimer2.pas line:117 addr 003E80A0

Call Stack: 

  $0001D2A1

  $000EA8B0

  $00022E09

  $0001AB05

  $0001CB66

  $0001D2A1

  $000230F4

  $00040CD1

  $0004059C

logout

Saving session...

...copying shared history...

...saving history...truncating history files...

...completed.

Deleting expired sessions...none found.

 

[Process completed]

Share this post


Link to post
Share on other sites

I have just checked my MacBook which I also (foolishly) updated and it does the same. It refuses to run any PTE apps. So it looks like a problem with sierra 10.12.2.

Share this post


Link to post
Share on other sites

Sierra 10.12.1

 

Share this post


Link to post
Share on other sites

Thank you. Afriend from my camera club, confirms that 10.12.2 doesn't run his PTE created mac app slideshows.

 

 

Share this post


Link to post
Share on other sites

I confirm this problem with PicturesToExe executables on MacOS Sierra 10.2.2.

We'll work on this issue.

Share this post


Link to post
Share on other sites

Thank you Igor, I assume it is a specfic problem with 10.12.2 and that using the V9 beta will not help?

 

Share this post


Link to post
Share on other sites

I apologize for this problem.

For some reason, system function in MacOS Sierra 10.12.2 can't load JPEG images. We'll change JPEG loader to fix this problem. The updated version should be ready soon.

P.S. Probably Apple will fix this issue in the next update of MacOS.

Share this post


Link to post
Share on other sites

I reported to Apple about this problem.

Also we're working on the alternate solution to fix this problem.

Share this post


Link to post
Share on other sites

Thank you Igor.

Share this post


Link to post
Share on other sites

Hi Igor, I can confirm that this works.  Just out of interest, what was the problem?

Share this post


Link to post
Share on other sites
5 hours ago, Almark said:

Hi Igor, I can confirm that this works.  Just out of interest, what was the problem?

Mark.

Thanks for checking!

For some reason in MacOS Sierra 10.12.2 a system function which loads JPEG images has stopped the work anymore. We had to include alternate JPEG decoder to fix this problem (same code as for PC). Now JPEG images always will work on Mac, because we use own code for JPEG loading.

Of course, it's very strange. I can't remember something similar on Windows. I didn't recieve a reply from Apple yet.

Share this post


Link to post
Share on other sites

Hi

sorry for the late reply. The latest update has fixed the problem, thank you.

I am assuming from the rest of the thread that it is not possible to view other peoples previously created shows unless Apple fixes the problem is that correct?

Many thanks

Paul

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0