Jump to content
WnSoft Forums
goddi

How to overlap MP3s?

Recommended Posts

Ignoring any software product differences, does this mean we work in different ways and are therefore looking for different features?

Peter

Yes.

There are numerous changes which could be made to improve what we have but I don't necessarily think that turning it into an "Audacity Plug-in for PTE" is the answer.

I have worked with it exclusively for a while and cannot fault it - but, as you say, we probably work in different ways. I like working with numbers and pre-visualising an effect rather than dragging things around and seeing what happens.

DG

Share this post


Link to post
Share on other sites

Gary,

No it hasn't! When I apply crossfading to music #2 there is no change to the start of music #1, only to the end of it where it overlaps with music#2. Are you 100% cast-iron sure that you are using the version of the piece of music that you think you are using?

Peter

===================

Peter,

Yes. I have tried different versions of PTE (7.04 and 7.03), and different mp3s and even Lin's mp3s and each time the beginning mp3 is affected. I see it does affect where we expect, overlapping the two mp3s.I will try to make up an AVI that will demonstrate my point. Give me some time...

Gary

Share this post


Link to post
Share on other sites

P.S.

Regarding the application of Crossfade to the first MP3.

It DOES fade the MP3 in, which is both logical and illogical at the same time.

It is logical if you consider that you might move the MP3 around or change the order of tracks.

However it is illogical that you should be able to apply crossfade to a track with no previous track?

DG

Share this post


Link to post
Share on other sites

P.S.

Regarding the application of Crossfade to the first MP3.

It DOES fade the MP3 in, which is both logical and illogical at the same time.

It is logical if you consider that you might move the MP3 around or change the order of tracks.

However it is illogical that you should be able to apply crossfade to a track with no previous track?

DG

==============================

DG,

Thanks for addressing one of my original questions. I think it is illogical because you can apply your own fade to the beginning MP3 if you want to, whenever you want to. Using Crossfade as it is now, affects the beginning audio of the 1st MP3, and it should not.

While you were making this posting, I created an AVI to demo my point, for others who might not see what I am trying to show.

See the attached for the demo.

Thanks, Gary

CrossfadeTest -1.zip

Share this post


Link to post
Share on other sites

It DOES fade the MP3 in...

No it doesn't! Following the sequence of events that I described above, and using PTE v7.0.3 with two MP3 files running under Windows 7 Home Premium 64-bit - it does NOT apply a fade-in to the start of music#1 in Track1 when adding a non-zero value to the "Crossfading" field of music#2 in Track1.

If this software does one thing for me and something different for you guys, there's a rabbit loose somewhere. As far as I know I haven't changed any Project Options that would influence the way PTE handles its sound files.

regards,

Peter

Editted to add two screen shots: post-4886-0-78300100-1327011149_thumb.jp post-4886-0-17698900-1327011163_thumb.jp

Capture2 with 9 seconds crossfading on second item

Capture3 with no crossfading on second item

Share this post


Link to post
Share on other sites

I don't know what to say peter.

I added one MP3 to a project; looked at the wave form (and listened); there was quite a loud first couple of seconds; I applied a 10 second crossfade in CUSTOMIZE; I updated the waveform in CUSTOMIZE and it showed no difference.

I then clicked OK and the Waveform opened up under the Slide List with a 10 second fade in and the loud first couple of seconds had turned into a fade in.

I went back into Customize and removed the Crossfade time and the MP3 was restored to original.

With just one MP3 it treats it as the SECOND MP3 if Crossfading is applied. Try it?

DG

Share this post


Link to post
Share on other sites

Peter,

This is very interesting. If I understood it correctly, I think that DG agreed that Crossfade produced a fade-in on the first mp3. So we need more 'rat terriers' to track down the rabbit!!! :rolleyes:

Every time I try it with different mp3s and different versions of PTE, it showed the same results. Even if I put in a single mp3, the beginning gets faded-in.

Did you see my AVI? Did I do something wrong?

I have Win7 Prof., 32-bit.

Gary

ADDED LATER: In his last post, I see DB gets the same results as I do.

ADDED LATER: Peter, I assume you clicked OK to get the waveform to refresh after changing the Crossfade to 9s.

===========================

No it doesn't! Following the sequence of events that I described above, and using PTE v7.0.3 with two MP3 files running under Windows 7 Home Premium 64-bit - it does NOT apply a fade-in to the start of music#1 in Track1 when adding a non-zero value to the "Crossfading" field of music#2 in Track1.

If this software does one thing for me and something different for you guys, there's a rabbit loose somewhere. As far as I know I haven't changed any Project Options that would influence the way PTE handles its sound files.

regards,

Peter

Editted to add two screen shots: post-4886-0-78300100-1327011149_thumb.jp post-4886-0-17698900-1327011163_thumb.jp

Capture2 with 9 seconds crossfading on second item

Capture3 with no crossfading on second item

Share this post


Link to post
Share on other sites

With just one MP3 it treats it as the SECOND MP3 if Crossfading is applied. Try it?

Dave,

Now that's interesting! I, too, get the fade-in applied if there is only one piece of music. Further investigation finds that applying Crossfading has the effect of applying a fade-in to the start of the selected item and a fade-out to the end of the immediately previous item: which is quite logical. As you indicated in a subsequent post, Crossfading is irrelevant to a single item and so should be greyed-out until there are two or more items in that Track. I think I would go one stage further and suggest that, for Crossfading to become not greyed-out, two or more sound files should have been selected in the Project Options...Music tab. For now, however, the important thing is that we've got the rabbit back in the hutch!

I assume you clicked OK to get the waveform to refresh after changing the Crossfade to 9s.

Gary, Yes I did!

regards,

Peter

Share this post


Link to post
Share on other sites

You know, I think that we all owe an apology to JEB?

In his excellent FAQ/Tutorial on Audio in V6.5 ( ) he covers the whole topic adequately.

Is the FAQ / Tutorials section needed?

I don't see many people suggesting that it be used in response to a question. (Ken does).

I propose that a standard question be introduced:

"Does the information in Tutorial XYZ not cover your query?"

DG

Share this post


Link to post
Share on other sites

IMHO

the general attitude is why hunt for an answer if somebody knows it

in other words " the master servant syndrome"B)

DAVE

THKS FOR THE MEMORY REMINDER

ken

Share this post


Link to post
Share on other sites

I know that most users would like to do everything in PTE. When it comes to audio, I use "sound forge". It is a great stand alone program which I have been using for many years. In the case of overlapping music pieces, I create the fade out of the first piece (2 steps with the mouse)then create the starting point of the second piece(could be a fade in or just at the original start of the piece - depending how I want to merge the two pieces together. I then copy the second piece to the clipboard and do a "mix" paste to where I want the 2 pieces to overlap. If I don't get the placement just right, I simply undo, move the cursor and reapply the mix. It works like a hot damn. :D

Greg

Share this post


Link to post
Share on other sites

Greg,

I agree that there are users out there who want to do everything through PTE. Sometimes I do a "proof of concept" build in PTE, just to get a feel for how it all might come together. Those sequences usually have only two or three sound files involved.

When it comes to assembling a complex soundtrack, I prefer something with a good graphical representation, including drag and drop capability. That's why I use Audacity (same thing as your "sound forge"?). I'm currently working on a ten and a half minute soundtrack for a sequence about Killhope Lead Mine in Weardale, in the north of England. It has 49 individual sound track items - 26 voice-over clips and 23 ambient sound recording clips - all recorded on location, all cross-faded into one another. For me, the advantage of Audacity over PTE is that I can see anywhere up to 20 tracks at the same time, rather than just one track at a time; and can have perhaps five or six of them opened at a size that I can do detailed work on.

Once the Killhope sequence is finished, later this year, I'll be posting it to the forum as there are no copyright issues associated with so doing - I own all the copyright; images, sound and assembly.

Peter

Share this post


Link to post
Share on other sites

Greetings Peter, et al.,

After looking at your two screen shots this morning, I now see why you were not seeing the fade-in of the first audio clip when you applied Crossfade. There are two ways to get into Crossfading.

When you applied your Crossfading, you clicked on Customize which revealed the Audio Clip Properties. When this happens, you can actually select either of the two audio clips that you want to apply the Crossface.

However, when I applied the Crossfading to my two audio clips, I just clicked on Crossfading button in the Music tab. (I did not get into the Customize window). When this is done, both audio clips are automatically highlighted. And we can get different results.

I think the problem with all of this is the definition of Crossfading is not being followed. The definition that seems to be accepted, and is in Jeb's excellent Tutorial (page 10), is as follows: Crossfading is when the end of one clip and the beginning of the following clip are faded out and in respectively and the faded segments are overlapped and merged together. Note that this does not include the fading-in of the beginning of the first audio clip.

When one uses the Customize/Audio Clip Properties/Crossfading approach, you can choose which audio clip you want to apply the 'Crossfading' to. If you select only the first audio clip, and apply 5s of Crossfading, what you actually get is only the fading-in of the first audio clip. This is really not Crossfading. The total length of the combined audio clips do not change.

If, however, you select only the second audio clip, and apply 5 s of Crossfading, you do get the crossfading that you should expect. The ending of the first audio clip and the beginning of the second audio clip are crossfaded and the beginning of the first audio clip is not affected and the total length of the two audio clips is reduced by the 5s, as expected.

Now, if you happen to select Crossfading in the Music tab, both audio clips are automatically highlighted and you get the Duration window that initially defaults to 5s. First of all, I think this should show Zero, not the suggest value of 5s. If you accept the 5s, or input your own number of seconds, the two audio clips do get crossfaded, but the first audio clip also get faded-in. This is not following the definition of Crossfading that is only supposed to affect the end of the first audio clip and the beginning of the second audio clip.

I think the entire Crossfading menus need to be reworked so that Crossfading only allows the overlay of two consecutive audio clips at a time. Under the current system, if you have more than 2 audio clips, all of them are automatically selected when you choose the Crossfading in the Music tab. The Crossfading function should be changed so that you can only select two consecutive audio clips and apply the crossfading only to them (without affecting the beginning of the first audio clip).

If you highlight the two audio clips in the Music tab and try to set the Crossfading seconds in the Customize/Audio Clips Properties window, it will not accept any seconds. Here is where I would expect to be able to do the crossfading of two selected audio clips, but you can't.

Perhaps the Crossfading buttom in the Music tab should be removed and only allow for Crossfading in the Customize/Audio Clip Properties window, and only two consecutive audio clips can be highlighted and only those two audio clips are affected with Crossfading.

Just my thoughts....Gary (rat terrier)

======================

No it doesn't! Following the sequence of events that I described above, and using PTE v7.0.3 with two MP3 files running under Windows 7 Home Premium 64-bit - it does NOT apply a fade-in to the start of music#1 in Track1 when adding a non-zero value to the "Crossfading" field of music#2 in Track1.

If this software does one thing for me and something different for you guys, there's a rabbit loose somewhere. As far as I know I haven't changed any Project Options that would influence the way PTE handles its sound files.

regards,

Peter

Editted to add two screen shots: post-4886-0-78300100-1327011149_thumb.jp post-4886-0-17698900-1327011163_thumb.jp

Capture2 with 9 seconds crossfading on second item

Capture3 with no crossfading on second item

Share this post


Link to post
Share on other sites

Gary,

I'd never noticed that "Crossfading" button on the music tab (but, there again, as I indicated in my response to Greg), I use Audacity for anything complicated. What we are up against here is a result of Igor's desire to make PTE as easy as possible for a novice to use. So we have more than one way of applying "Crossfading". Unfortunately, one way of doing it applies a fade-in to the wrong end of the wrong piece. I firmly believe that the software, whilst being easy to use, should also steer the novice user in the correct direction. For a cross-fade, that means selecting which two pieces you want to crossfade.

I'll open a new topic in the "Ideas and suggestions" section and link it back to this topic.

regards,

Peter

Share this post


Link to post
Share on other sites

Could I make a suggestion?

I think that the problem, as Gary says, is with the CROSSFADING Button and not with the Project Options>Audio Clip Properties.

Furthermore I think that It could be either a bug or a fundamental logic problem.

When CROSSFADING is clicked then BOTH MP3 files are selected (if there are 3 MP3 files 3 are selected) and there is no way to remove the first MP3 from the process.

I suggest that Igor be advised of this and await his thoughts - mine are that the CROSSFADING button needs another look.

It should not set a FADE IN on the first MP3 - even though it can be removed manually afterwards.

DG

Share this post


Link to post
Share on other sites

Could I make a suggestion?

I think that the problem, as Gary says, is with the CROSSFADING Button and not with the Project Options>Audio Clip Properties.

Furthermore I think that It could be either a bug or a fundamental logic problem.

When CROSSFADING is clicked then BOTH MP3 files are selected (if there are 3 MP3 files 3 are selected) and there is no way to remove the first MP3 from the process.

I suggest that Igor be advised of this and await his thoughts - mine are that the CROSSFADING button needs another look.

It should not set a FADE IN on the first MP3 - even though it can be removed manually afterwards.

DG

=========================

DG,

Actually, the only time Crossfading works properly is when you are using the Audio Clip Properties/Crossfading radio button and you have selected the second of two audio clips (or any other audio clip except the first one, in that Track). If you selected the first audio clip, you only get it to fade-in. And if you select both audio clips, you can't make any adjustments to the seconds.

I think it is a bug AND a logic problem.

Gary

Share this post


Link to post
Share on other sites

I'm going to be a little pedantic here: a BUG is when code is not working as designed. We do not know precisely what Igor and the team designed the code to do. It may be a bug; it is certainly working in an unusual manner. Igor should give some serious thought to making it behave in a more logical (to the user) manner; hence my topic in the Ideas and Suggestions section.

Peter

Share this post


Link to post
Share on other sites

I'm going to be a little pedantic here: a BUG is when code is not working as designed. We do not know precisely what Igor and the team designed the code to do. It may be a bug; it is certainly working in an unusual manner. Igor should give some serious thought to making it behave in a more logical (to the user) manner; hence my topic in the Ideas and Suggestions section.

Peter

=============

Peter,

Ok.....let's call it bugelogic? :D

Sorry, I could not resist...

Gary

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...