Jump to content
WnSoft Forums
tom95521

Hardware antialiasing on or off?

Recommended Posts

My Nvidia card was set to "enhance the application setting" but I think it is better when set to "override the application setting"?

Tom

 

nvidia_aa.jpg

Share this post


Link to post
Share on other sites

Tom,

Did you set "Edge antialiasing" option for an object in the Objects and animation editor? It seems to be OFF in your example. By default, it's ON in all new Image/Video/Rectangle objects.

Share this post


Link to post
Share on other sites

Hi Igor,

I was testing Jean-Cyprien's new Block Set style. It does appear the aa is turned off. I will do further testing.

Thanks,
Tom

Share this post


Link to post
Share on other sites

I set wait for keypress on slide 3 for time accurate comparison and then screen capture the resize 200% (no AA) using Faststone Capture 9.0 . All the A1,B1,C1,D1 cube images that show on the left side of the screen have edge anti-aliasing enabled (not on the frames, just the images). I still notice slightly more jagged edge with Nvidia AA off. It could be my imagination but I think I see a slight difference. If it does not hurt the graphics performance I will keep Nvidia anti-aliasing override enabled.

Thanks,
Tom

 

 

 

aa_comparison.jpg

Share this post


Link to post
Share on other sites

Tom,

Send me your project with one slide. I will check it.

Antialiasing for Image and Video objects in PTE should work absolutely ideally without any defects.

Forced antialiasing from NVIDIA may add a grid of visual artefacts in the middle of an image. 

Share this post


Link to post
Share on other sites

Hi Igor,

Attached is cube array project. It is based on a multiple image style so there is more than one slide (Sorry, I should have deleted the other slides). I have slide 3 set to loop. I only notice the problem in the top three rows on left side of screen A1,B1,C1. Row D1 in lower left of screen seems to be perfect. Nobody else has mentioned a problem so maybe it's just my 62 year old eyes. :( I did not know the hardware AA would cause interference with software AA so will return to the normal mode "enhance the application setting".

Thanks,
Tom

Update. In my subjective opinion having FXAA enabled looks the best (edges of cubes smooth) of all the choices. This is independent of Mode option. This does not fix Publish Show as HD video, it still has the alias problem (for me at least).

https://filedn.com/lpb9iXQfO0Sj6nON93sDIbL/PTE/cubes_aa_test_tom95521.mp4

nvidia_aa_fxaa.thumb.jpg.9721f5167c10557cfac1c5b3d0b89d56.jpg

cubes_aa_test_tom95521_Dec9-2018_6-12-34.zip

Share this post


Link to post
Share on other sites

Tom,

Thanks, I see this problem. When an object has a certain sharp angle in 3D space the antialiasing doesn't look perfect or looks completely off. I will think how to fix it in PTE 10.

We can easily enable antiliasing from NVIDIA/AMD, but I'm afraid to see visual artefacts in some case. Because large images in PTE are constructed from an array of small textures. And we need a fine control to disable antialiasing on internal edges of such textures. I 'll perform new checks.

Share this post


Link to post
Share on other sites

Hi Igor,

The hardware AA solution does not currently appear to fix the publish to HD video option. The stair step pattern is still visible. Hope it's not too difficult to solve.

Thanks,
Tom

 

Share this post


Link to post
Share on other sites
On 12/8/2018 at 9:54 PM, tom95521 said:

My Nvidia card was set to "enhance the application setting" but I think it is better when set to "override the application setting"?

Tom,

We just finished a code of a new edge anti-aliasing algorithm for PTE 10. It will give much better visual result than all previos versions.

Share this post


Link to post
Share on other sites

Igor,

Thank you for working on this important feature. It will be a noticeable improvement when publishing to video.

Thanks again,
Tom

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...