Jump to content
WnSoft Forums
Pieter

Scaling of time range (or not)

Recommended Posts

Hello,

Another question regarding time range.

In the slide options window  is a checkbox called “Scale key frames in object (on time change)”. Unchecked this function ensures that keyframes remain at their absolute value when the duration of a slide is adjusted. This work perfectly.

But, Is there also a possibility to make the “time range per object" absolute and thus leave its value unchanged when changing the duration of a slide?

Thanks,

Pieter

Share this post


Link to post
Share on other sites

I believe that the scaling is intended to work in the same way as key-frames so unticking the scaling box in Slide Options would give absolute figures to the Time Range on a change of slide duration.

However, I "think" that there is a bug in there somewhere and I am taking it up with Igor.

At this time I would advise NOT changing slide duration when you are constructing an animation. It "might" cause you a problem. Choose a duration greater than you will need and "trim" it afterwards.

DG

 

Share this post


Link to post
Share on other sites

The problem seems to be that the Scaling (or not) of the Time Range takes place correctly but the figures in the Time Range boxes are not updated.

....and now I cannot reproduce it!! :)

DG

Share this post


Link to post
Share on other sites

For example: I have a slide with a duration of 5 seconds and a time range 0-2500 for an object in that slide.

Than I adjust te slide duration to 10 seconds, of course with the scale keyframes box unticked in de slide options.

I was hoping the result would be that the time range remains at 0-2500ms for that object, but it changed to 0-7500ms (so the extra 5 seconds duration were also added to the time range).

The values in the time range boxes are updated accordingly, and show 0-7500.

Pieter

 

Share this post


Link to post
Share on other sites

I confirm the problem with Time Range and "Scale keyframes..." option. If Time Range were changed it works wrong after a change of a slide duration. We'll try to fix it soon.

Share this post


Link to post
Share on other sites
29 minutes ago, Igor Kokarev said:

I confirm the problem with Time Range and "Scale keyframes..." option. If Time Range were changed it works wrong after a change of a slide duration. We'll try to fix it soon.

Igor, is it also possible to reinstate the dragging of the vertical lines at each end of the O&A timeline to adjust the time range?

This worked in V8 but not in v9

Jill

Share this post


Link to post
Share on other sites
Quote
6 hours ago, Igor Kokarev said:

I confirm the problem with Time Range and "Scale keyframes..." option. If Time Range were changed it works wrong after a change of a slide duration. We'll try to fix it soon.

 

Thanks Igor. 

 

As Jill suggests, it would indeed even be better to be able to drag the time ranges to its values.

Pieter

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×