Jump to content
WnSoft Forums
Sign in to follow this  
alrobin

[Utility 4 PTE] PTE-5 Adjustor

Recommended Posts

I have finally completed the first version of my "Adjustor model" for PTE verson 5. (You can download it for free from the link below).

Based on MS "Excel 2000", "PTE-5 Adjustor" is a spread-sheet-based interactive model for examining PTE project files and making basic changes to image names, and timing parameters.

With it you can:

a)view your "duration", and "transition" timing parameters in tabular form;

b)identify which slides contain more than one keypoint;

c)rename your slides;

d)spread the transitions over the total time;

e)pin certain times and spread the slides evenly between them;

f)manually input actual times at which transitions occur, and have the other timing parameters recalculated accordingly;

g)manually input new slide durations and transition times, and reflect these in the project timing;

h)transfer new timing and slide names, etc., back to PTE project file format, and confirm the results in PTE.

The second sheet of the model contains a brief list of instructions. Please contact me if you wish further information or assistance in using this model. Enjoy! :)

PTE_5_Adjustor.zip

Share this post


Link to post
Share on other sites

Hi Al,

I highly appreciate your work. Your PTE-5 adjustor will surely help me. I tried to manually insert a different transition time in column P but pressing the button "calc on dur'r" didn't change the transition time. How can I change the transition time for a few slides?

Share this post


Link to post
Share on other sites
I highly appreciate your work. Your PTE-5 adjustor will surely help me. I tried to manually insert a different transition time in column P but pressing the button "calc on dur'r" didn't change the transition time. How can I change the transition time for a few slides?

Hi, Hartmut,

You must be using "Default settings" for these slides. The model will only allow you to modify transition times where they have been specifically input to PTE, either by changing them on the timeline, or in "Customize slide". It's a problem with the script - Adjustor would have to make up a few extra lines and so far I have only made changes to the lines which are there already. Sorry about that.

If they show as "greyed out" after you run "calc", you can't change them. But it's not difficult to adjust them in PTE, especially on the timeline.

Share this post


Link to post
Share on other sites

I just noticed that the spreadsheet does not identify "synched" and "non-synched" shows properly. Just a minor glitch, but an obvious one. See revised model here:

PTE_5_Adjustor.zip

Share this post


Link to post
Share on other sites
I have finally completed the first version of my "Adjustor model" for PTE verson 5. (You can download it for free from the link below).

Based on MS "Excel 2000", "PTE-5 Adjustor" is a spread-sheet-based interactive model for examining PTE project files and making basic changes to image names, and timing parameters.

With it you can:

a)view your "duration", and "transition" timing parameters in tabular form;

b)identify which slides contain more than one keypoint;

c)rename your slides;

d)spread the transitions over the total time;

e)pin certain times and spread the slides evenly between them;

f)manually input actual times at which transitions occur, and have the other timing parameters recalculated accordingly;

g)manually input new slide durations and transition times, and reflect these in the project timing;

h)transfer new timing and slide names, etc., back to PTE project file format, and confirm the results in PTE.

The second sheet of the model contains a brief list of instructions. Please contact me if you wish further information or assistance in using this model. Enjoy! :)

PTE_5_Adjustor.zip

Al,

This is a great tool somewhat in the mode of SY(p) which I was hoping would be updated to cater for Version 5. You have done a very good job.

Jeff

Share this post


Link to post
Share on other sites

Al,

I tried to use your PTE-5 Adjustor and I have a problem : I click on "open", then "choose directory". I choose a directory where I'm 110% sure there is at least one PTE file but there is no "avalaible PTE files" in the list. :(

I have Microsoft Office Excel 2007.

Do you think there is an incompatibility with this version ?

Share this post


Link to post
Share on other sites

Hi, Dom,

It's possible that there is an incompatibility with the latest version of Excel, which I don't use - no one else has complained about it yet, though, and I just tested the version listed, and it still works for me.

Are you trying to open an "exe" file, perhaps? It only works with the project ".pte" files.

By the way, I have posted the latest version (#2) of the model on my web site, http://www.alrobinson.com/av/technology1.htm . The only change is that it shows the slides with O&A actions when you first open it, instead of after the first calculation. Otherwise it works exactly the same as before.

Ciao,

Al

Share this post


Link to post
Share on other sites
Are you trying to open an "exe" file, perhaps? It only works with the project ".pte" files.

No, I try to open .pte files.

I'm afraid there is s an incompatibility with the latest version of Excel. :(

Share this post


Link to post
Share on other sites

Maybe someone else with the same version of Excel as Dom could give it a try.

Share this post


Link to post
Share on other sites

excel 2002 opens Al's first version

and the revised version also works

and excel 97 SR-2 also works but will only open 1 of 3 pte's

revised version will open 3 of 3

will send Al the 3 pte's to check

fast moving into unknown territory:(

ken

Share this post


Link to post
Share on other sites

Thanks to those of you who tried out the Adjustor Model - it looks like it may not compatible with Excel versions 2003 and later - that's the way it is with Microsoft and their Visual Basic. They did that to me with Excel 2000 vs 97, too, and I had to make a new model. But I don't have a need to keep current any more, so version 2000 is probably the last one I will use (sorry Judy and Dom, and anyone else using the later versions).

Thanks, Ken, too, for testing, and to Dom, Hartmut and Jeff for your kind words! Ken, I opened all 3 of your pte files with no problems.

Maybe JC will get his "SY(P)" updated after v.5 is "finalized".

Share this post


Link to post
Share on other sites

POINT FOR OTHERS

excel 97 SR-2 also works but will only open 1 of 3 pte's

i would have thought excel 97 would have opened it as well -- old stuff not always better -- first time i had ever used Al's program so i cant realy comment as to cause

maybe we can get some more members to try Al's work and get some will and will not data for future

ken

Share this post


Link to post
Share on other sites

Al, thanks for sharing this.

It worked fine for me with Excel 2003 SP2. I'm not sure what Ken is talking about loading more than one project, but once I open a project, the "Open" button disappears. I changed some slide durations and some transition times, clicked the necessary buttons and saved the revised project out. It worked fine and it showed my changes when I opened in PTE.

Share this post


Link to post
Share on other sites
Mary

when i went to the folder of pte's excel 2002 recognized 3 pte's

but excel 97 only 1 of the 3

ken

Ah-ha! I understand now. When I went to the folder where my pte's are stored, it recognized about 8 of them. So I guess that means it worked fine for me in Excel 2003 SP2.

Share this post


Link to post
Share on other sites
Ah-ha! I understand now. When I went to the folder where my pte's are stored, it recognized about 8 of them. So I guess that means it worked fine for me in Excel 2003 SP2.

Mary,

Thanks for the feedback! Glad to hear it works in at least one installation of Excel 2003. Wonder why Judy's doesn't open it.

Share this post


Link to post
Share on other sites
Wonder why Judy's doesn't open it.

It's hard to tell without knowing the exact sequence of steps she takes in opening the Adjustor and then where it hangs for her. My first guess would be that it has something to do with her security settings in Excel in "Tools\Options\Macro Security". Or perhaps it has something to do with her anti-virus software. Also, I wonder whether she has Service Pack 2 installed (or if that even makes a difference). We would need more information to trouble-shoot.

Share this post


Link to post
Share on other sites

Hey,

It workt for me in exell 2003 sp2.

wonderfull tool!!

plan it to use also for print-out of the show.

thanks

Luc M

Share this post


Link to post
Share on other sites
..... My first guess would be that it has something to do with her security settings in Excel in "Tools\Options\Macro Security". Or perhaps it has something to do with her anti-virus software. Also, I wonder whether she has Service Pack 2 installed (or if that even makes a difference). ...

Good point!

Share this post


Link to post
Share on other sites
It workt for me in exell 2003 sp2.

wonderfull tool!!

plan it to use also for print-out of the show.Luc M

Luc,

That's great - so the problems others are having are not because it's Excel 2003.

Share this post


Link to post
Share on other sites

For those having problems opening and running Adjustor, you need to make sure you have certain visual basic "references" available in your Excel setup.

Open MS Excel, and click on "Tools/Macro/Visual Basic Editor" to open the "MS Visual Basic" page.

On the VB page, click on "Tools/References" to open the "Available References" menu.

Make sure you have the following 5 items clicked as shown in the screenshot below

- Visual Basic for Applications

- MS Excel 9.0 Object Library (or equivalent for your version of Excel)

- OLE Automation

- MS Office 9.0 Object Library (or equivalent)

- MS Forms 2.0 Object Library

The attached screenshots illustrate where to locate these items.

post-215-1181314113_thumb.jpg post-215-1181314125_thumb.jpg post-215-1181314101_thumb.jpg

Share this post


Link to post
Share on other sites

Thank you for your patience with me:) I have gone through settings and they seem ok. Security is set to "Low" But I cannot open the "VB references" in the macros as it is grayed out. The VB Project is password protected. Could that be why? I am not able to edit the macro's or vb code.

My system hangs at the point of attempting to choose a directory opening a directory. I click on ":Choose A Directory" and then select any directory (I have tried several choices). The little fingers just strum forever (nothing happens).

I use Norton AV --I have tried disabling AV. / Office Pro 2003. I do NOT have SP2 installed. Maybe that has something to do with it.

I will keep tinkering.

Thanks you so much,

jk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...