Jump to content
WnSoft Forums
Sign in to follow this  
alrobin

[Utility 4 PTE] PTE-5 Adjustor

Recommended Posts

But I cannot open the "VB references" in the macros as it is grayed out. The VB Project is password protected. Could that be why? I am not able to edit the macro's or vb code.

Hi, Judy,

You need to open "References" from a blank spreadsheet (before you open "Adjustor"). The model is password protected, so you won't be able to open any of the macros themselves. However, the "References" items for your system should be available from a blank, unprotected spreadsheet.

The difficulty in running could mean you need to add another "Library reference item" (I have 4 of them ticked off in my version of Excel), or it could mean that you need SP2.

Hope this helps some.

post-215-1181496814_thumb.jpg

Share this post


Link to post
Share on other sites
Maybe JC will get his "SY(P)" updated after v.5 is "finalized".

Hi, Al

Yes, I am working on a new Sy(P) 2.00, but it's a big job. Perhaps a first release in 3-4 weeks.

Happy that forum members are waiting for it.

Share this post


Link to post
Share on other sites

I am very happy (and a little embarrassed) to tell you, that after updating Office 2003 with all the latest goodies, PTE adjuster works wonderfully. So if anyone wants to know...there may be some issues if you are not up-to-date with service packs.

Thanks to you all--I might have given up if you hadn't kept encouraging me.

A Happy Camper:)

jk

Share this post


Link to post
Share on other sites

JUDY

you dont need to feel embarrassed, you learned something and hopefully your "learning" will benefit others, and by telling about it you dont leave Al trying to fix it:

ken

Share this post


Link to post
Share on other sites
I am very happy (and a little embarrassed) to tell you, that after updating Office 2003 with all the latest goodies, PTE adjuster works wonderfully.

Judy,

You've made my day! So glad you got it working, and that it's not a bug in the programming! Now if we could just get Dom's copy working too, everyone would be happy! :)

Share this post


Link to post
Share on other sites

Unfortunately it doesn't work in Excel 97. The spreadsheet opens, but when I try to retrieve a .pte file, the program cannot see any. I created a separate folder with only one pte file in it, but no luck, the program could not see the file.

I tried using Quattro, but that was no use at all, I guess it didn't like VB. :(

I also am not buying constant upgrades from MS either. I am now retired, and my win2000 machine is going to stay that way, no XP or (horrors!) Vista for me, and Office 97 is it. Actually, I use WordPerfect in preference to Word anyway.

Share this post


Link to post
Share on other sites
Unfortunately it doesn't work in Excel 97. The spreadsheet opens, but when I try to retrieve a .pte file, the program cannot see any. I created a separate folder with only one pte file in it, but no luck, the program could not see the file.

I tried using Quattro, but that was no use at all, I guess it didn't like VB. :(

I also am not buying constant upgrades from MS either. I am now retired, and my win2000 machine is going to stay that way, no XP or (horrors!) Vista for me, and Office 97 is it. Actually, I use WordPerfect in preference to Word anyway.

Yes, that's unfortunate - MS made some major changes to Excel and VBA when they updated to Office 2000, and I took time to update the previous Adjustor for PTE v.4 to make it compatible. Unfortunately, I don't have time at the moment to go back and create a special version for v.5 in Office 97.

JC's "Sy(P) v.2" will probably work for you, and others having problems with Adjustor, when he gets it updated.

Share this post


Link to post
Share on other sites

A new version (5.3) of PTE-5 Adjustor is available on my website.

I've added the ability to view the following information about the objects on each slide:

- number, name, type, mode, "parent/child" level, and which objects use PZRO actions.

I've also added the ability to globally change the mode of each object to "fit to slide", "cover slide", or "original". No other object parameters can be modified in the model.

Instructions are included on the second page of the spreadsheet.

Share this post


Link to post
Share on other sites

Al

excel v2002- sp3 opens a pte from ver 5 final

and also

excel v97-sr2 opens a pte from ver 5 final

guess you not just a pretty face:)

ken

Share this post


Link to post
Share on other sites
A new version (5.3) of PTE-5 Adjustor is available on my website.

I've added the ability to view the following information about the objects on each slide:

- number, name, type, mode, "parent/child" level, and which objects use PZRO actions.

I've also added the ability to globally change the mode of each object to "fit to slide", "cover slide", or "original". No other object parameters can be modified in the model.

Instructions are included on the second page of the spreadsheet.

Al,

Have downloaded new version and tried the "objects" facility on a test PTE project. Adjustor gets the object data ok and changes the Mode to any of the options. However when I press the "transfer" button, the screen switches to the data file, the file data flashes as if changing the data, but it just goes on and on and never stops. I had to exit using Cltr + alt +del to stop the program. I am using Excel 2000.

Regards

Jeff

Share this post


Link to post
Share on other sites
Al,

Have downloaded new version and tried the "objects" facility on a test PTE project. Adjustor gets the object data ok and changes the Mode to any of the options. However when I press the "transfer" button, the screen switches to the data file, the file data flashes as if changing the data, but it just goes on and on and never stops. I had to exit using Cltr + alt +del to stop the program. I am using Excel 2000.

Hi Jeff,

It does take quite a while to get through all the images if you are using a lot of objects. But, transferring shouldn't take any longer than reading the data in the first place, so maybe there is a glitch that didn't show up in my testing. If you send me your pte file, I'll try to run it through (don't need pics or music files).

alrobin @ alrobinson.com (omit the spaces).

Share this post


Link to post
Share on other sites

Hi Al,

I wonder if you or anyone can help :

Once I have done all the procedure of getting PTE-5 Adjustor to work...and it seems to works OK until I get the error message : "Erreur d'exécution '9' : L'indice n'appartient pas à la sélection ", sorry this is in french but even, I do not know the meaning !

I looked into some forums but found no explanations nor solutions to get out this trap.

From there I'm stuck : I cannot go further.

Henri

Share this post


Link to post
Share on other sites

Henri,

Je regrette d'avoir vous dire que moi, aussi, je ne le comprend pas! :(

At what point do you receive this message? Is the problem only when you access the "object" features of the model? Does the previous version work OK? It's still on my website as per a previous link.

Perhaps it has something to do with commands in French? Sorry, I don't know how to help you out with this problem.

Share this post


Link to post
Share on other sites
However when I press the "transfer" button, the screen switches to the data file, the file data flashes as if changing the data, but it just goes on and on and never stops. I had to exit using Cltr + alt +del to stop the program. I am using Excel 2000.

Jeff,

You should be able to stop the loop in Excel by hitting the "break" key, so you don't have to completely reboot the system.

Did you try it out on several different PTE files?

Share this post


Link to post
Share on other sites

Igor,

You are so welcome! Hope some people find it useful.

It was the least I could do in light of all the work you put into the new PTE features! :)

Share this post


Link to post
Share on other sites
Henri,

Je regrette d'avoir vous dire que moi, aussi, je ne le comprend pas! :(

At what point do you receive this message? Is the problem only when you access the "object" features of the model? Does the previous version work OK? It's still on my website as per a previous link.

Perhaps it has something to do with commands in French? Sorry, I don't know how to help you out with this problem.

Al,

This what I do :

1) I open Excel (Windows XP)

2) I make sure that the five References Libraries are ticked

3) I open the PTE-5 Adjustor

4) I click Open, Select a .pte project file with the Browser

5) This opens an Excel files with a long list of item (single column) which quicly dispear to leave room for the error message window to pop up

[i don't know how to send screen picture !]

here are the first twelve rows of the ptesource spreadsheet :

[main]

filetype=Project file of PicturesToExe

CreationTool=PicturesToExe v5.00 beta 8u

globalversion=1

minorversion=10

projectname=Danses

type=Save

IsTemplate=0

ProjectFilePath=C:\Gilles\PHOTOS CANON\Diaporamas PTE\Danses\Diaporama danses\Danses.pte

CanRestore=0

IsPreview=0

stw_show=0

I wonder if this will help you in understanding what is wrong otr what i do wrong.

Rgds,

henri

Share this post


Link to post
Share on other sites

Henri,

It sounds like you are finding the PTE files you want OK, but the problem is with the loading of the "ptesource.xls" spreadsheet. I don't know what would be wrong - maybe too large a file??

If you send me your "pte" project file (just the .pte file, no pics and no music) I will try to run it through Adjustor to see if I get the same error message. ( alrobin @ alrobinson.com) - skip the spaces.

Share this post


Link to post
Share on other sites
Henri,

Je regrette d'avoir vous dire que moi, aussi, je ne le comprend pas! :(

At what point do you receive this message? Is the problem only when you access the "object" features of the model? Does the previous version work OK? It's still on my website as per a previous link.

Perhaps it has something to do with commands in French? Sorry, I don't know how to help you out with this problem.

Al,

PTE-5 Adjustor V5_1 works perfectly but not V 5_3, does this means anything to you and helps you understand what the problem may be ?

henri

Share this post


Link to post
Share on other sites
Jeff,

You should be able to stop the loop in Excel by hitting the "break" key, so you don't have to completely reboot the system.

Did you try it out on several different PTE files?

Al,

Yes I can break into the loop without a reboot. have tried it again with another test file with the same results. have sent uou a separate email with the test PTE file to see if you get the same results.

Regards

Jeff

Share this post


Link to post
Share on other sites
PTE-5 Adjustor V5_1 works perfectly but not V 5_3, does this means anything to you and helps you understand what the problem may be ?

Henri,

As I mentioned in my return email, your pte file seems to work fine on my system - it must have something to do with the version of Excel - what version are you using? Others have successfully run the model in versions 97 through to 2003. I use 2000, myself, for developing the model. Will send you some screen-caps of my results with your file. Please try to run the model on a few other simple examples.

Share this post


Link to post
Share on other sites
Yes I can break into the loop without a reboot. have tried it again with another test file with the same results. have sent uou a separate email with the test PTE file to see if you get the same results.

Jeff,

As per my email, I had problems running your file, too, so will do some investigating to determine the cause and publish the necessary revisions. You have obviously found a scenario that I hadn't made allowances for.

Thanks again for your feedback!

Share this post


Link to post
Share on other sites

Note that a new version 3 of "PTE-5 Adjustor" is available on my website as PTE-5_Adjustor_3.zip.

It has been revised to properly accommodate PTE 5 files containing images that have not been edited in O&A. Thanks to Jeff Evans for alerting me to this problem. Sorry for any inconvenience. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×